Düzeltme SORUN: Sunucu PHP sürümünü çalıştıran ancak WordPress 5.1.6 3.2.1 5.2.4 En Az gerektirir.

Tüm Bildirimi tanınmış değildir için o kurmak veya yapmak yükseltmek'Leri daha yeni bir sürümü 3.2Bu, gerekli olduğu daha yeni bir sürümü yüklü 5.2.4.

Sunucu 5.2.4 sürümünü yüklemek için daha eski PHP sürümü yüklemek ise WordPress 3.2.1Görünecektir hata / Mesaj "Sunucunuz PHP sürümü 5.1.6 WordPress 3.2.1 gerektirir çalışan ama en azından 5.2.4 edilir".
Sorun PHP yükselterek çok basit bir şekilde çözülebilir, ancak bunu yapmadan önce birkaç şey dikkate alınmalıdır. İlk olarak, yükseltme PHP bir paylaşılan barındırma mevcuttur. Yani sunucuya yönetici erişiminiz olmalıdır yükseltme yapabilirsiniz (adanmış sunucu veya VPS). İkinci olarak, belgelemek ve yükseltmeden önce farkında olmalıdır PHP'nin yeni sürümü verilmemiştir bu sunucu üzerinde barındırılan hataları diğer siteler.

için için en yaygın olarak kullanılan işletim sistemi Web sunucuları (Agreart ve / WHMA) yapmak nasıl göstereceğim CentOS 5.2.10.x 5 32-bit PHP yükseltme.

5.1.x 5.2-bit CentOS 5.x 32.x PHP yükseltme

1. Standart paket ile birlikte PHP (örneğin php-mcrypt) yüklü olan paketler / modülleri kontrol edin. Herhangi biri, silinmiş veya actuzlizate gerekmektedir.

Kurulu paketleri kontrol etme:

rpm-qa | grep php

old_php_version

2. Depolarıdır ekle Gerekli yükseltmek'S PHP sürümü.

nano / etc / yum.repos.d / CentOS-Testing.repo

Yeni dosya (CentOS-Testing.repo) Aşağıdaki kodu (copy / paste) ekler:

[C5-test]
name = CentOS-Test 5
baseurl = http://dev.centos.org/centos/ $ releasever / test / $ basearch /
etkin = 1
gpgcheck = 1
gpgkey = http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing
includepkgs = php *

Ctrl + X Dosya CentOS-Testing.repo kaydetmek için.

3. Yum aracılığıyla Güncelleme PHP:

yum update

4. Yeniden / httpd :

service httpd restart

Httpd restart ve paketlerin kurulu sürümü kontrol ettikten sonra:

new_php_version

Modüller / paketler herhangi bir hata olup olmadığını kontrol edin:

php-v

PHP Yükseltme / CentOS 32-bit (i386).

Düzeltme SORUN: Sunucu PHP sürümünü çalıştıran ancak WordPress 5.1.6 3.2.1 5.2.4 En Az gerektirir.

Yazar hakkında

Stealth LP

Kurucu ve editör Stealth Ayarlar2006 tarihi.
Linux işletim sistemlerinde (özellikle CentOS), Mac OS X, Windows XP>, Windows 10 ve WordPress (CMS) Deneyim.

Leave a Comment