[Fix PHP 7.2 / PHP 7.3] PHP Uyarı: Tanımsız sabitin kullanılması (bu PHP'nin gelecekteki bir sürümünde bir Hata verecektir)

PHP 7.2 si PHP 7.3 daha fazla istikrar, esneklik ve birçok yeni özellik getirdiler; eski kutsal yazılar, fişe takmakATV ve WordPress teması onları tamamen sindirmeyin.

Sunucuyu PHP 5.x'ten PHP 7.2 veya PHP 7.3'e yükseltmeye karar verdiğinizde, bazı kod uyumluluk öğelerini de dikkate almanız gerekir. Aksi takdirde aşağıdaki gibi hatalarla karşılaşmak çok mümkündür:

PHP message: PHP Warning: Use of undefined constant CONSTANT - assumed 'CONSTANT' (this will throw an Error in a future version of PHP)

Bu hata mesajı her zaman görünür PHP kodu belirsiz bir sabit bulursanız. Tüm sürümlerinde geçerlidir. PHP 7.2 si PHP 7.3.

Örneğin, eğer varsa:

echo $_POST[email]; // "mail" sabiti tanımlanacak ve kod şöyle görünecek:

echo $_POST["email"]; // - Kaydettikten sonra, PHP hatası "PHP Uyarı: Tanımsız sabitin kullanılması (bu, PHP'nin gelecekteki bir sürümünde bir Hata verecektir)" kaybolacaktır.

"Bu işareti, sembolünü koymayı unutursanız da oluşabilir"$Msgstr "Bir değişkenin adının önünde.

[Fix PHP 7.2 / PHP 7.3] PHP Uyarı: Tanımsız sabitin kullanılması (bu PHP'nin gelecekteki bir sürümünde bir Hata verecektir)

Yazar hakkında

Gizlilik

Gadget ve BT anlamına gelen her şey hakkında tutkulu, 2006'ten stealthsettings.com'a zevkle yazıyorum ve sizinle bilgisayarlar ve macOS, Linux işletim sistemleri hakkında yeni şeyler keşfetmeyi çok seviyorum. Windows, iOS ve Android.

Leave a Comment